Temporary Interruption of Services

Incident Report for AppCard

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 08:34 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 06:21 EDT

Identified

We identified an issue being caused by the cloud provider.
This incident has caused some degradation to several services however we are observing recovery on services.
Posted Oct 20, 2025 - 06:16 EDT
This incident affected: Digital Coupons, New Terminal (NTR), and JBrain.